Intermittent connection issues

Incident Report for Dyspatch

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 13:04 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2026 - 12:02 PDT

Investigating

Some users may be experiencing intermittent connection issues. Our team is actively investigating.
Posted Jun 18, 2026 - 11:56 PDT
This incident affected: Dashboard.